Quire

Cryptographic Message Syntax

From Quire, the open reference··1 min read

Il Cryptographic Message Syntax (CMS) è uno standard IETF per messaggi protetti crittograficamente. Esso può essere usato per firme digitali, digest, autenticazione o cifratura di ogni forma di dati digitali.

Il CMS è basato sulla sintassi del PKCS#7, che a sua volta deriva dallo standard Privacy-Enhanced Mail. La versione più recente del CMS è specificata nel IETF RFC 5652 (vedi anche IETF RFC 5911 per aggiornamenti dei moduli ASN.1 conformi a ASN.1 2002).

L'architettura del CMS è costruita attorno a una gestione delle chiavi basata su certificati, come i profili definiti dal gruppo di lavoro PKIX.

Il CMS è usato come chiave crittografica componente di molti altri standard crittografici, come S/MIME, PKCS #12 e il protocollo RFC 3161 per la marca temporale digitale.

OpenSSL è il software open source che può cifrare, decifrare, firmare e verificare, comprimere e decomprimere documenti CMS.

Voci correlate#edit

Collegamenti esterni#edit

  • IETF RFC 5652 (Cryptographic Message Syntax (CMS), in uso)
  • IETF RFC 3852 (Cryptographic Message Syntax (CMS), obsoleto)
  • IETF RFC 3369 (Cryptographic Message Syntax (CMS), obsoleto)
  • IETF RFC 2630 (Cryptographic Message Syntax, obsoleto)
  • IETF RFC 6268 (New ASN.1 Modules for Cryptographic Message Syntax (CMS) and S/MIME, in uso)
  • IETF RFC 5911 (New ASN.1 Modules for Cryptographic Message Syntax (CMS) and S/MIME, aggiornato)
  • IETF RFC 5753 (Usa Elliptic Curve Cryptography con CMS, in uso)
  • IETF RFC 3278 (Usa of Elliptic Curve Cryptography (ECC) Algorithms bel Cryptographic Message Syntax (CMS), obsoleto)
  • IETF RFC 5084 (Usa AES-CCM e AES-GCM Authenticated Encryption bel the Cryptographic Message Syntax (CMS), in uso)

This article is mirrored from “Cryptographic Message Syntax” on Italiano Wikipedia, revision 134842929, written by Wikipedia's contributors and licensed CC BY-SA 4.0. Editing it here creates a Quire copy with its own history.

Synced with Wikipedia revision 134842929 · just now